Device idle drains more than 30%, awakes every 10mins while in sleep mode, doze not working

Hi, my phone (t08) has been awake while I have it in sleep when I'm not using it. Has been happening for a week now IDK what happened but the battery graph shows it waking in the middle of the night about every 10mins... I recently reset my phone because the sound was missing options and now this... Before I reset there wasn't any problems and after I reset it was fine but few days later this happened... It says "device idle" eating more than 30% battery for 1 day idle in total, since my last charge it's eaten up 17% with 17hrs idling. I REALLY do not want to reset the phone again, it is so annoying. I downloaded every app I had before reset and haven't downloaded anything new so no apps are Awakening the phone but Device idle is the only thing eating battery. I've also noticed DOZE isn't doing anything to stop the battery drain...
I have accubattery and it says it is in doze mode 49% of the time, normally before this happened it would be 80-90%.

I have a 500mah battery and as you can see device idle uses more than 1700mah.

Show Accepted Answer

Guest Quick Reply (No URL, BBcode or HTML)

Last post by scassin
1 hour ago
Last post by pearl.hessel
52 minutes ago
Last post by srolfson
1 hour ago
Last post by vwilderman
4 hours ago
atrix bricked?
Started by tyrel24
Last post by monroe.kshlerin
4 hours ago
Last post by ashley.kerluke
3 hours ago
Last post by pwolff
38 minutes ago
Last post by thurman82
2 hours ago
Last post by pearlie.turner
3 hours ago
Last post by urban42
4 hours ago
Last post by abernathy.stacy
4 hours ago
Last post by rhiannon41
2 hours ago