Qualcomm HS-USB Port Auto Disconnects

I am using a Zuk Z1 which has lost its GPS functioning so i read around the forums and came to find out that the only way to fix it would be to flash the stock rom (Lenovo_ZUK_Z1_7DF). I was previously on Screwd Rom (Oreo) and thus i tried to get back to the stock rom. I was unable to succeed in my task using QFIL or QDLoader hence i chose the "Flash Stock Rom " in the "All in one Tool".
It put my phone on the other stock rom (CM12.1).
Now all i want to do is to use QDLoader/Qfil to install the stock rom (Lenovo_ZUK_Z1_7DF) So that i can recover my GPS functioning. The problem i m facing is that My phone quickly leaves the Qualcomm HS-USB Mode (which is required for flashing) in 5-7 seconds, thereby stopping my flashing.
Pls help me out with this problem pls.

P.S. I have got ADB Debugging "ON" and got the correct drivers set up for my PC.

Show Accepted Answer

Guest Quick Reply (No URL, BBcode or HTML)

Last post by muller.sterling
2 hours ago
Last post by bins.celestino
2 hours ago
Last post by tschuster
37 minutes ago
Last post by kiera.lang
4 hours ago
Last post by chad00
4 hours ago
S5 Neo Frp
Started by donny87
Last post by fausto69
2 hours ago
Last post by darby.terry
52 minutes ago
Last post by wilton50
2 hours ago
Last post by slubowitz
1 hour ago
Last post by alfred.emmerich
1 hour ago
Last post by ernser.noe
4 hours ago
Last post by lorna.nolan
2 hours ago
Last post by yvette52
18 minutes ago
Last post by fnitzsche
1 hour ago
sis file 2 cab?
Started by gwill
Last post by bartoletti.isom
1 hour ago
Last post by hkiehn
30 minutes ago
Last post by lavina.bruen
4 hours ago